Chapter 5

Exploring Navicat and Sequel Pro
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Skills you will learn: Features of the basic user interfaces of the Navicat and Sequel Pro front end
programs for MySQL.

Unlike Microsoft Access, Navicat and Sequel Pro are not stand-alone database applications, but
instead clients that allow you to run commands on the MySQL server. For a fuller discussion of the
differences between desktop databases and server databases, see Chapter 5 of The Data Journalist.

This tutorial is primarily intended to assist with using Navicat to connect to a MySQL server
installed locally on your own computer, and you may need to obtain additional information to
connect to a remote server, such as login credentials. You will also need permission to access the
remote server and query databases it hosts.

The current version of Navicat as of August 2017 is version 12. Most of the images seen here are
from version 11, but the material has been checked for compatibility with version 12 and any small
differences have been noted in the text.

Navicat

Navicat is a well-developed and refined front end for MySQL, available in both Windows and Mac

versions.

There are several licence levels of Navicat, to connect to MySQL and other server databases. For the
purposes of this tutorial, we will focus on the most basic and affordable of these, Navicat Essentials.
You can see the complete range of features and capabilities in different versions at
www.navicat.com.

When you first open Navicat Essentials, you will see a screen something like this.


http://www.navicat.com/
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The first step you will need to take is to make a connection to the MySQL database. This tutorial
assumes you have already installed MySQL on your computer. If you plan to install it on your own

computer and have not yet done so, please see the tutorial Installing and Configuring the
MySQL Setrver.

To initiate a connection, click on the Connection icon and choose MySQL. Fill out the connection
dialogue (General tab) with the settings seen here, replacing the password with the password you set
for the MySQL root user. If you didn’t set a password, leave the password field blank (we suggest
setting a password for security reasons).

¥ MysQL - New Connection X

General Advanced SSL S5H HTTP

Connection Mame: |MyF|rstC0nnect|on . |

Host Mame/IP Address: |12?.D.D.1 |

Port: 3306

Save Password

Test Connection Cancel

MySQL, as a matter of convention, uses port 3306. The host name can also be entered as
“localhost” but entering the IP address of the local machine, 127.0.0.1, will avoid possible
connection problems in some configurations. If you are logging into a remote server, you will need
the IP address of that server and any instructions from the server provider on logging in.

If you are logging on as a user other than root, change the User Name setting accordingly.

To ensure the connection works, click on Test Connection. If it doesn’t work, it may mean you
have set the configuration options incorrectly, or the server may not be running.



When you are satisfied everything is correct, click OK.

If you double click on the name of your connection, in the table of contents area (in Navicat
parlance, called the navigation pane), you will see all of the existing databases on the server. If you
have not yet created your own, it will look like the image below, and you will see only the system
databases. These should not be altered.
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You should probably create a new database for each new project. To create a database, right click on
the connection name and choose New Database.

B A e LR ] [T [ETITye W e

v X MyFirst=

. Open C ti
nfor pen Connection

Close Connection le
my's

perft B New Query...

sy's . )
Edit Connection...

Mew Connection »
Delete Connection
Duplicate Connection...

Open Database
Mew Database...

Console...
Execute SOL File...
Flush k

ke
1

Colar L
Refresh

Connection Information...

That will bring up the New Database dialogue.
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General

Database Name: |M)rFir5tDatabase |
Character set: Default character set v
Collation: | ~ |

Cancel

Note: If you have version 12 of Navicat, the character set field may come up as empty to indicate use of the defanlt
character set; leaving it empty is the equivalent of entering “Defanlt character set” in version 11.)

You will need to give your database a name. It makes sense that the name be related to the project.

The default character set is Latin1. This will be suitable for most applications using western
languages, but if you want, you can choose one of the character sets in the dropdown list, such as
Unicode UTF-8 or a language-specific character set such as traditional Chinese, Arabic or Russian,
depending on the characters you expect to exist in your data.

When you are done, click OK, and your new database will appear in the table of contents.
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To select the database for use, double click on its name.

Please see the tutorial Making Tables and Importing Data into MySQL to learn how to create
new tables using Navicat.

Once you have created tables, they will appear below the Tables header in the table of contents, if
you click on the expansion arrow. They will also appear under the Objects tab when the table icon is
selected. They are now ready for analysis.

Most of the analysis you will do involves writing queries. The companion tutorial, Getting Started
with Queries in MySQL, covers this important functionality in Navicat and Sequel Pro.



There is one other really useful feature in Navicat, and that is the ability to switch directly to the
MySQL command prompt, for entering SQL queries and other commands such as LOAD DATA
INFILE without having to open the command line utility.

Right click on the database name, and choose Console, or go to the Tools menu and choose
Console. A console window will open, with functionality that duplicates that of the command line
tool, complete with the MySQL> prompt.

You can save commands as well as open previously saved commands.

Here, the console is pictured with a query completed.
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| Donor ID | Donor Last | Donor First | Donor Initial | Donor Address | Donor City | Donor Pro
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| 1 | Smith | Joanne | © | 22 hny Street | Calgary | AE
| 2 | Jones | Stewve | NULL | 57 Moneybags Court | Toronto | CH
| 3 | Leblanc | Carole | X | 212 Tormentine Cape | Dieppe | HB
| 4 | Johnson | Gerald | F | 55 Honexistent Way | Calgary | AB
| 5 | S5tephenson | Brenda | NULL | 21 Anywhere Avenue | Brandon | MB
| & | Tremblay | Monigue | © | 16 Rue Vide | Hontreal | QC
1ema | 7 | Calhoun | Dawvid | NULL | 8% Apex Landing | Hamilton | oW
| & | Mill= | Harold | B | 65 Atlantic Lane | Halifax | HS
1 9 | White | HMel | D | 27 Sandstone Bluff | Charlottetown | PE
| 10 | Silwers | Wanda | T | 55 Assini-Red Fork | Winnipeg | MB
o Fomm - Fomm Fom e B Fom—

10 rows in set

my=gl>

If you wish to see a history of commands you have run since opening the connection, click on
Tools>History Log.

There are a number of options that can be set from Navicat.
Options is an item under the Tools tab.

Many of the choices deal with how the interface looks, and we’ll leave those to you to explore.
However, there are a few worth noting.

If you open Editor under the Appearance tab you can control whether you see line numbers in SQL
queries. Line numbers make queries easier to read and are the default.

Under Data and Grid you can enable or disable a limit on the number of records shown in a table or
query. The default is 1,000.

Sequel Pro

When you first open Sequel Pro, you are presented with a screen that will allow you to make a
connection to the MySQL database.
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In the standard tab, enter a name for the connection. This can be anything you like. The host should
be entered as 127.0.0.1, the username will be root, unless you are connecting as other than the root
user, and the password is whatever password you have set for the root user. If no password is set,
leave this field blank. The port can be left as the default. Generally speaking, on a Mac, which uses
an operating system based on Unix, you can also connect using the socket tab.

When you have entered the necessary details, click on test connection. If the parameters are entered
cotrectly and the MySQL server is running, you should get the message "connection succeeded."

Click Connect to complete the connection.

To create a database, choose Add Database from the Database menu.
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Next, give your database a name and set the encoding and collation. The encoding is the character
set used to represent characters; in this case the default latinl is used. The collation determines how
characters are compared to each other in comparison operations such as =, > and <>. The ci
collations are case insensitive, which is the way journalists would likely prefer it. The default
collation should be fine.

Database Mame: AGreatDataba sﬁ{

Database Encoding: | Default (latin1)

Database Collation: Default (latin1_swedish_ci)

of o]l

Cancel Add

When you are done, click Add and the database will be created and a connection established to it.

Taking a look at another database, already created, we can see that tables are listed along the left side
of the user interface, in the Tables area. If you click on a table, you can make it active, and greyed
out icons across the top of the screen will become available for use.
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Select Database Structure Content Relations Triggers Table Info Query Table
TABLES Search: | Donor_ID 2l = = Q,
Doﬂor_ID Donor_Last Donor_First Donor_lnitial Donor_Address Donor_City Donor_Prov

1 Smith Joanne 0 22 Any Street Calgary AB
2 Jones Steve 57 Moneybags Court Toronto ON
3 Leblanc Carole X 212 Tormentine Cape Dieppe NB
4 Johnson Cerald F 55 Nonexistent Way Calgary AB
5 Stephenson Brenda 21 Anywhere Avenue Brandon MB
6 Tremblay Monique 0 16 Rue Vide Montreal Qc
7 Calhoun David 99 Apex Landing Hamilton ON
8 Mills Harold R 65 Atlantic Lane Halifax NS
9 White Mel D 27 Sandstone Bluff Charlottetown PE
10 Silvers Wanda u 55 Assini-Red Fork Winnipeg MB

TABLE INFORMATION

|E) created: 2016-0...
|8l engine: InnoDB
&) rows: 10

Bl size: 18.0kiB

u encoding: latini

In the Content tab, you can view the table fields and records. There is also a Search functionality
above the table that allows you to filter records based on criteria that you set.
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Here a filter has been entered to see only records that have Calgary in the Donor_City field. Clicking
Filter activates it. Clicking the small X on the right side of the filter window will remove the filter.
There is a range of possible operators available in a dropdown list.
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The Structure tab shows the fields and data types. You can make changes to the table structure,
including the data types and field names, here.
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Structure Content Relations Triggers Table Info Query Table History Users Console
Field Type Length Unsigned Zerofill Binary Allow Null Key Default Extra Encoding Collation Comm.
Donor_ID INT b » » NULL None H o -
Donor_Last  VARCHAR & 255 » MULL Mone b= -+ }+]
Donor_First  WVARCHAR 5 255 » NULL None = = b
Donor_Initial VARCHAR  $ 255 ] NULL None o A &
Donor_Addr.. WVARCHAR 5 255 » NULL None = = b
Donor_City WARCHAR &+ 255 ] NULL None o A &
Donor_Prov.. VARCHAR 4 255 ] NULL MNone 3 -+ }+]
Donor_Age  INT 2 1N - » NULL None H % 2
Donor_Gen.. VARCHAR 4 255 ] MULL Mone b= -+ }+]
Donation_D... DATE = NULL None = v v
Donation_s... DECIMAL 4202 » » NULL MNone H + -
PartyCode VARCHAR 3 255 » NULL None = & &

The Table Info tab does as its name suggests; it provides metadata about the table, including the
CREATE TABLE statement that was used to create it.
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Structure Content Relations Triggers Table Info Query Table History Users Consol

Type: | InnoDB Created at: Aug 24, 2016, 5:44:40 PM
Encoding: | cp1252 West Europea... [ Updated at: Mot available
Collation: | latin1_swedish_ci
Mumber of rows: 10 Data size: 16.0 KiB
Row format: Compact Max data size: 0B
Avg. row length: 1,638 Index size: OB
Auto increment: Not available Free data size: 0B

Comments:

Createsyntax: | CREATE TABLE “Donations’ (
“Donor_ID" int(11) DEFAULT NULL,
“Donor_Last™ varchar(255) DEFAULT NULL,
“Donor_First™ varchar(255) DEFAULT NULL,
“Donor_Initial® varchar(255) DEFAULT NULL,
“Donor_Address™ varchar(255) DEFAULT NULL,
“Donor_City™ wvarchar(255) DEFAULT NULL,
“Donor_Province™ varchar(255) DEFAULT NULL,
“Donor_Age™ int(11) DEFAULT NULL,
“Donor_Gender™ varchar(255) DEFAULT NULL,
‘Donation_Date® date DEFAULT NULL,

*MNanatd an Amanint® Aacimal F200 22 DECALILT ML

The query icon is used to open the query window, in which SQL queries are written. See the tutorial
Getting Started with Queries in MySQL for a full discussion of writing queries using Sequel Pro.

Sequel Pro allows you to control many aspects of your MySQL database and database objects. Many
of the functions are beyond the scope of this tutorial. However, we will review some of the most
important tools.

Let’s first look at the File menu:
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Save Query ~¥S
Import... 4Rl
Export... O XE
Close Window O 3BW
Close Tab FEW
Print... ®P

The New Connection Window and New Connection tab options allow you to create a new
connection to a MySQL server in either a window or tab. You are unlikely to do this in the normal
course of a journalist's work..

The Open option allows you to open an existing query, while Save Query allows you to save the text
of a query.

Import allows you to import external data, or a MySQL dump file.
The View menu largely duplicates the large icons on the main toolbar.
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Show Tab Bar 8T
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Custom Query H6
Back In History T s
Show Console 3K
Clear Console Bk
Show Navigator ~NEN

Display Binary Data as Hex

Hide Toolbar T
Customize Toolbar...

Enter Full Screen ~HF




The Database menu provides options for administering the MySQL database.

pEIEe=: Table Bundles Windov

Go to Database... {+38D
Add Database... ATA
Delete Database... E

Duplicate Database... L
Rename Database... i
l Alter Database...

Refresh Tables ~¥R
Flush Privileges ~{r38F
Refresh Databases {+3#R
User Accounts... #EU
View Using Encoding [

Open Database in New Tab

Show Server Variables... {38V
Show Server Processes... 3P

Here, you can add and delete databases, duplicate databases, rename them, or alter their attributes.
You can also refresh the view of tables and databases within the user input, and open a new
database in a separate tab. You can also create new user accounts in MySQL.

The Table menu provides two highly useful options (we're not showing the whole menu here).

Copy Create Table Syntax 4 3C
Show Create Table Syntax... 35

The Copy Create Table Syntax allows you to copy the SQL command that would recreate the table.
The Show Create Table Syntax option simply allows you to view it.

Here is an example for the Political Donations database we've been using.



Create syntax for TABLE 'Donations’

CREATE TABLE “Donations® (

2/ “Donor_ID" int(11) DEFAULT NULL,

s/ “Donor_Last® wvarchar(255) DEFAULT NULL,

«/  "Donor_First™ varchar(255) DEFAULT NULL,

s “Donor_Initial® varchar(255) DEFAULT NULL,
s/ “Donor_Address™ varchar(255) DEFAULT NULL,
7/ “Donor_City" wvarchar(255) DEFAULT NULL,

¢ “Donor_Province® varchar(255) DEFAULT NULL,
s "Donor_Age® int(11) DEFAULT NULL,

| “Donor_Gender® varchar(255) DEFAULT NULL,

1 “Donation_Date® date DEFAULT NULL,

2/ “Donation_Amount® decimal(20,2) DEFAULT NULL,
s/ “PartyCode’ wvarchar(255) DEFAULT NULL

14|} ENGINE=InnoDB DEFAULT CHARSET=latinl;

=

Save As... Copy

Having access to the syntax is especially useful for either recreating a similar table, or quickly
creating a table with different field names or data types.

Before we conclude, it's worth addressing Bundles. Bundles are a bit like add-ons in some other
applications; extra code that provides additional functionality. They are not particularly well
supported, but there is limited information available on this GitHub page:

https://github.com/sequelpro/Bundles

There is one bundle, however, that is built in to the distribution of Sequel Pro. It allows you to
convert any table or query display to JSON.

Right click on the table or query result, and choose BUNDLES>Copy>Copy as JSON.


https://github.com/sequelpro/Bundles

Search: | Donor_ID =] [ = = || Q,

IDnnnr_ID Donor_Last Donor_First Donor_Initial Donor_Address Donor_City Donor_Province
1 Smith — 22 Any Street Calgary AB
2 Jones EGW ith Col N 57 Moneybags Court Toronto oM

opy wi olumn Names i ,
3 Leblant Copy as SQL INSERT 212 Tarmentine Cape Dieppe MNE
4 Johnsol 55 Nonexistent Way Calgary AB
5 Stephei 21 Anywhere Avenue Brandon MB
6 Trembl Duplicate Row 16 Rue Vide Montreal Qc
7 Calhou Delete Row 99 Apex Landing Hamilton ON
8 Mills RS Atlantir | anea Halifaw NS
9 White Bundles [ 2 Caopy [ 2 Copyas JSON ~C 13
10 Silvers Wanda u 55 Assini-Red Fork Winnipeg MB

The JSON will be copied to the clipboard. From there, you can save it in a plain text file with a
JSON extension. Here's one row of the above copied using the Copy as JSON bundle.

{

"data":

[

"Donor_ID": 1,

"Donor_Last": "Smith",
"Donor_First": "Joanne",
"Donor_Initial": "O",
"Donor_Address": "22 Any Street",
"Donor_City": "Calgary",
"Donor_Province": "AB",
"Donor_Age": 77,
"Donor_Gender": "F",
"Donation_Date": "2016-08-21",

"Donation_Amount": 1500,

"PartyCode": "Red"



